E-Maculation
https://emaculation.com/forum/

Error -39
https://emaculation.com/forum/viewtopic.php?f=20&t=10196
Page 1 of 1

Author:  maryofscots [ Tue Jun 04, 2019 8:29 pm ]
Post subject:  Error -39

Every time I open an app in SS, I get a -39 error. My SS Sharing folder is in my documents folder. I've tried both opening them up from within the "UNIX" folder and dragging them to the Mac OS 9 desktop.




Also...
I was also able to install a game from a .cdr image that I created from the original CD. Disk one is mounted on the desktop as it should be to run the game but when I open the installed game icon, SS crashes.

2017 MacBook Pro with Touch Bar
OS 10.14.5
MacOS 9.0.4
SS 2.5

Author:  Cat_7 [ Tue Jun 04, 2019 9:13 pm ]
Post subject:  Re: Error -39

Quote:
I've tried both opening them up from within the "UNIX" folder and dragging them to the Mac OS 9 desktop.


This will not work, you have to copy the program onto the hard disk on which you have Mac OS 9 installed. So open the hard disk, and drag the program from the Unix disk into the hard disk window.

Best,
Cat_7

Author:  maryofscots [ Tue Jun 04, 2019 9:39 pm ]
Post subject:  Re: Error -39

No luck. I dragged the folder directly to the emulated HD (It's sitting right next to the system folder) and it still didn't work.

I take that back. I dragged the toat installer .sit file to the HD. Extracted it, installed it and was able to open it successfully. I did the same thing to a different program (Classilla) that didn't need extracting. I clicked on the program icon and got the -39 again. It's in the same volume as Toast so I'm stumped.

Author:  adespoton [ Tue Jun 04, 2019 9:43 pm ]
Post subject:  Re: Error -39

Probably best to keep your files compressed when moving them over from the shared folder; you may be running into permissions errors during the copy process.

Author:  maryofscots [ Tue Jun 04, 2019 11:24 pm ]
Post subject:  Re: Error -39

Thank you! Classilla works now. Yay!

Question 1:

Now the second issue from my original post. I created a .cdr file of Traitors Gate (disk 1) game from my own CD. I was able to mount it on the emulated desktop and install it. It's sitting in the applications folder of the MacOS9HD. With disk one still mounted, I try to open the installed game and SS crashes. No warning or error codes to troubleshoot it.

Question 2:

When I try to install from a downloaded version of Titanic (from macintosh garden) I get a funky error code. From a mounted disk I get
"Sorry! Error at line 1622 (type -1856, code -43). Click OK to return to finder.
Is this just a corrupted file or is it something else?

Author:  adespoton [ Wed Jun 05, 2019 4:28 am ]
Post subject:  Re: Error -39

Do you have a full install of OS 9 from a CD on that disk image, or did you just get a copy of the Redundand Robot emergency boot disk? If the second, it isn't a full install, and is not recommended for playing games, as you'll be missing all sorts of components.

Next, did you follow the MG instructions for those games?

Quote:
After install and before running for the first time, do the following two things:
– Install file 'scripts.cxt' from archive 'Traitors_Gate_SW_Patch.sit'; ie drag into the folder 'Traitors Gate' on your hard disk and click 'Yes' to exchange/overwrite the installed file. This solves the bug with duplicate Sound in intro/mission breefing.
– Copy the files in the archive 'locale.sit' into the folder 'locale' in the same folder where TG was installed, ie 'Traitors Gate folder'. Click 'yes' to replace some files.
– Now to the (unfortunate) persons who doesn´t read/speak Swedish; open the file 'Lingo.ini' in the folder 'Traitors Gate'. Edit 'set gLanguage = "Sv" into 'set gLanguage = "En"', close and save. You can also set 'Du' for Dutch version. Anything else here defaults to Dutch text and sound.
– To be sure and/or if you did run w/o applying the two steps above; delete any content in the folder 'Prefs' in 'Traitors Gate folder'.


Titanic: Adventure Out of Time requires a CD compatability patch available on MG to r un correctly. However, MG has 6 games named Titanic, so I'm not sure which one you're talking about.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/