Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Building and running SheepShaver under Ubuntu 18.04

Wed Jul 03, 2019 8:33 am

I have SS built and starting up, but nomatter what I do I get this message:
"Cannot map Low Memory Globals: Operation not permitted."
I'm on Ubuntu 18.04. Anyone have any pointers about it?

Re: Building and running SheepShaver under Ubuntu 18.04

Wed Jul 03, 2019 1:31 pm

Hi, this has to do with security measures on Linux.

First, try to run SheepShaver as root
If it does not work, see here:

Cannot map Low Memory Globals: Permission denied.
Due to a change in how programs in Linux are allowed to use memory, before using SheepShaver you need to set a variable in the file /etc/sysctl.conf. Add this line: vm.mmap_min_addr = 0
and do as root:
echo 0 > /proc/sys/vm/mmap_min_addr
Post a reply