Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Best configure parameters to build SheepShaver!!!

Thu Jul 04, 2019 4:40 am

Hi,

First, thank you for any answer! Are What the best and more suitable configure parameters to build newer version SheepShaver in Linux 64 bits or MacOS?

Re: Best configure parameters to build SheepShaver!!!

Thu Jul 04, 2019 7:05 am

This works on Fedora 30

git clone https://github.com/cebix/macemu macemu-master
cd macemu-master/SheepShaver
make links
cd src/Unix
NO_CONFIGURE=1 ./autogen.sh
./configure --enable-sdl-video --enable-sdl-audio --disable-vosf
make
strip SheepShaver

Run SheepShaver as root to prevent the "Cannot map Low Memory Globals: Operation not permitted" error.

Best,
Cat_7

Re: Best configure parameters to build SheepShaver!!!

Thu Jul 04, 2019 6:16 pm

I've been wondering... since SheepShaver needs root access to be able to address the memory regions it uses to function correctly, what mechanisms could we put in place from SELinux/etc. to minimize the security footprint outside of memory addressing?

Also, how difficult would it be to provide SheepShaver with its own virtual memory space that starts (for SheepShaver) at address 0?
Post a reply