Error when running game: Assertion failed: RenDev
Page 1 of 1

Author:  camila [ Mon Jan 20, 2020 8:04 pm ]
Post subject:  Error when running game: Assertion failed: RenDev

Hi. I'm 100% new to sheepshaver and I finally set it up properly. I'm having issues trying to get my Harry Potter game to work. See error below...

The game: https://www.macintoshrepository.org/198 ... er-s-stone
This is driving me insane. I don't know how to fix this. I just downloaded the original file, I wasn't sure what to do with the update file.

Author:  24bit [ Tue Jan 21, 2020 1:08 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

You may want to read the notes on the page made 1017, where mrdav has originally uploaded the game file.
https://macintoshgarden.org/games/harry ... rers-stone
User SkyCapt has pointed out his findings confirming that the game does need a OpenGL compatible GPU and a G3 Mac.
Sorry to spoil your idea of running the game with Sheephaver, but that is not going to happen. :(

Currently there is no way to run the game with an emulator, I´m afraid.
If any, maybe QemuPPC will run the game some day, if a compatible GPU would be emulated.

Author:  camila [ Tue Jan 21, 2020 5:09 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

darn it.... I feared that may be the case so I switched over to my windows and tried to run it, only to be faced with a different error. I've seen people run this on win 10, I don't know why I can't.

Thank you for your detailed response.

Author:  camila [ Wed Jan 22, 2020 2:07 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

Hi. I saw your messages, but I can't reply because I am new.

To the moderators: I'm sorry that this is diverging away from sheepshaver.. but I can't message them back so I have to address this somehow.

I also have a Surface Book 2, maxed out, with 2 graphic cards. I can't remember off the top of my head, but I hate the thing because it automatically chooses the integrated graphics. I don't spend a lot of time on my PC so learning to switch graphics card is its own issue. This all relates because every time I try and do this I get the following error.

I suspect this is happening because of my integrated graphics card.

Author:  Ronald P. Regensburg [ Wed Jan 22, 2020 4:38 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

You now have three approved posts in the forum. You should be able to send PMs now.

Author:  24bit [ Wed Jan 22, 2020 7:09 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

As for the PM, I was suggesting to look for compatible hardware, if playing the HP games is a must.
A Mac Mini G4 would spring to mind, or a low end Core2Duo Hackintosh with Snow Leo and Rosetta.

SurfaceBook2 looks like the Airbus A380 to me technology wise, where an old Boing 727 would be compatible. ;)
That said, my Optiplex 755, AMD HD5450 does play the HPCOS game fine in Windows 10.
(I´m not familiar with the HP anthology, its the one where the kids miss the train and almost hit a 747 with their Ford Anglia.)

Author:  camila [ Wed Jan 22, 2020 8:54 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

ok so this seems like a long-term project for me. i want to thank you for all your help and for your archive, that's awesome. i will come back and update you when i get this darn game to work.

Author:  camila [ Thu Jan 23, 2020 5:43 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

This is for the game, Harry Potter and the Philosopher's / Sorcerer's stone (2001)
Updated for 2020

I'm happy to report... after HOURS of troubleshooting... I FINALLY got the game to work. Most of my troubleshooting steps did not show up on google so I'll share my experience for any future people who want to play this game. As stated previously, since this will not work on sheepshaver, I had to switch to win 10. I was determined to get this game to work without having to invest in an older computer.

I looked up more than one youtube tutorial for this. The files seem to be the same, some have more files than others so I can't remember which one that was the best file.

https://www.youtube.com/watch?v=7m9z-Ba764c (source video)
https://gf.wiretarget.com/harry_potter.htm (google will say that it's dangerous, but it is not)

Replace files as instructed in
C:/ Program files (x86) / EA games / Harry Potter / System
Do not copy over. Paste and replace.

https://www.play-old-pc-games.com/compa ... -tutorial/
this is for Direct X, but do not select Direct X during the game's graphic choice start up - chose system renderer instead.

Change compatibility settings
Windows XP (service pack 2/3)
Change DPI settings
High DPI override, check
Scaling performed by SYSTEM

Apply to all users just to prevent from doing this again

Target: after the URL and ("")s type -window -c
otherwise, the game crashes

Not all users will get this error message but if you do...
Rename HP.exe to a file name that makes sense to you (Harry 1.exe)
Create a shortcut to your desktop

Optional Step 3b
Set up xpadder with your controller and save your settings with the corresponding name (Harry Potter game) ** highly recommend

Start up game. Stop. Don't click anything else for the next 3 minutes or your screen / exe will freeze. It will prompt which graphics to use. Always pick System Renderer.

Options - Set up graphics to the highest, since this is running on a better computer anyway and 32 bit
Keyboard - this might be empty, assign the keys

Game should work now

I had issues with some of my key inputs not working. For example I couldn't move my character regardless what keys I assigned it to but jump and wand worked. To reset these controls I went into my Documents / EA games and deleted the entire Harry Potter folder.

The next time I started up, it refreshed my folders and cleared cache. I was able to assign keys again.

NOTE: You do need a mouse for this game for the spell learning portions. You can try your trackpad but it will be very hard.

Author:  adespoton [ Thu Jan 23, 2020 6:32 pm ]
Post subject:  Re: Error when running game: Assertion failed: RenDev

It's probably worth noting that CodeWeavers has WINE working on Catalina now as well -- so this should also be possible via that avenue.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group