Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

Cmd key often misses, and always if too fast

Wed Jan 29, 2020 10:19 pm

I write a lot of text in Word 4 using OS 9.2 under SheepShaver, and I tend to work fast and use keyboard shortcuts a lot.

The Cmd (Apple, Command) key frequently "misses". That is, the application will think I'm typing the letter without the Cmd key pressed. Thus, I might type Cmd-f and quickly start typing what I expect will go into the Find dialog box, and when I look at the screen, I see the text 'f' has been added, along with what I was searching for, in my text window. This means I have to slow down and keep checking to make sure the Cmd key has indeed been engaged; and of course Save (Cmd-s), copy/paste and other functions sometimes don't work and instead I get extraneous junk in the files I'm writing.

This happens on two different laptops and my iMac; it's definitely not a physical problem with my Cmd key. And it doesn't happen to be in OS X, e.g. when using Word 2016. It's been happening randomly in SheepShaver since I installed vesion 2.4 in 2014.

Today, after upgrading to SheepShaver 2.5 on my iMac, I discovered a reproducible problem, and I think it might have to do with the Cmd key being "pressed" very fast, triggering the same problem. I use TypeIt4Me to expand sequences quickly and type phrases and editorial instructions that I use over and over, and this has worked fine for years.

But using the new SheepShaver now, every time I type a sequence that has such expansions, I get simply:
which I think maybe means TypeIt4Me is copying the sequence I want, then sending out a Cmd-v to paste it in, and because of this SheepShaver bug, Word thinks it's seeing a v rather than Cmd-v and just adds a v. I can't be sure but it's the only explanation I have for the 'v' appearing in place of the string I want.

Does anyone know of a way to ensure the Cmd key is always picked up, and/or why this problem appears in SheepShaver 2.5 and not in the 2014 version (2.4) I was using before (while the random Cmd problem appears in both versions).

Thanks for anyone's insights, as always.

Re: Cmd key often misses, and always if too fast

Thu Jan 30, 2020 10:45 am

If this is a timing issue, you could try disabling JIT Compiler (in SheepShaver preferences > Miscellaneous). Some actions in SheepShaver will become slower.

Note that you need to quit / shut down SheepShaver after changing settings in SheepShaver preferences.

Re: Cmd key often misses, and always if too fast

Thu Jan 30, 2020 10:55 am

Thanks. Tried that and it doesn't seem to change anything. (I've left it unchecked. What sorts of things will run slower with is unchecked?)

Re: Cmd key often misses, and always if too fast

Thu Jan 30, 2020 3:39 pm

I tried TypeIt4Me 4 in OS9 in SheepShaver 2.5, 12 January 2020 build, and it works perfectly here, both for expanding abbreviations and for typing the clipboard content. Tried it in SimpleText and AppleWorks documents, both inside SheepShaver and in the shared folder (Unix). Works by typing the abbreviation, also by selecting from the menu bar menu or from the popup menu for which I chose the command key in TypeIt4Me preferences.

Now what could be different in your setup?
Last edited by Ronald P. Regensburg on Thu Jan 30, 2020 3:51 pm, edited 3 times in total.

Re: Cmd key often misses, and always if too fast

Thu Jan 30, 2020 6:37 pm

I can also not reproduce the other issue with the command key you mentioned. Even when I hit both keys almost at the same time, command-V or command-S work as expected.

Could these issues be restricted to Word 4?

Re: Cmd key often misses, and always if too fast

Thu Jan 30, 2020 8:06 pm

It shows up in Hypercard as well. It doesn't happen all the time (except for the TypeIt4Me sequences); I do a lot of typing and it shows up periodically but very often.

Re: Cmd key often misses, and always if too fast

Fri Jan 31, 2020 10:11 am

So, apparently for you it happens in Word and in Hypercard. Here, TypeIt4Me works fine in SimpleText and in AppleWorks. I do not use either Word or Hypercard. Can you try TypeIt4Me in SimpleText or ClarisWorks/AppleWorks. Then we can decide if it is a general problem on your setup or if it is limited to certain applications.

Re: Cmd key often misses, and always if too fast

Fri Jan 31, 2020 10:32 am

I tried it. The same thing happens on both Simpletext and Clarisworks on my iMac -- any long TypeIt4Me string comes out just as 'v'.

Re: Cmd key often misses, and always if too fast

Fri Jan 31, 2020 11:23 am

I tried Word 4 and Word 5 in SheepShaver 2.5, 12 January 2020, and in SheepShaver 2.4, 9 July 2018, both on my machine with macOS Mojave 10.14.6.

No difference between SheepShaver 2.5 or 2.4. (Except that 2.4 does not work correctly with Unix on the APFS file system that was introduced in High Sierra.)

cmd-C and cmd-V
Work in Word 4 as long as one inserts a short pauze between pressing the cmd key and the letter key.
Do not work at all in Word 5 (I needed to use the Edit menu).

Works once in both Word 4 and 5, but then Word freezes.

I do not see these issues with other applications. Even a very long piece of text is inserted by TypeIt4Me in SimpleText and AppleWorks documents correctly. It takes quite some time for all the text to be written to the document, though.

Re: Cmd key often misses, and always if too fast

Fri Jan 31, 2020 11:29 am

Again, short expansions work OK for me. It's only long ones, expanding into maybe 50 or more characters, that generate the 'v'.

But the Cmd key typed manually still misses quite often, especially (but not exclusively) when I first come back to a window from another window (another System 9 application) or from OS X. I might do Cmd-O to open a file, and instead I get an 'o' replacing whatever text was previously selected. And this happens frequently (but inconsistently) in both Word and Clarisworks, among other applications.

Puzzling. Maybe it's an interaction with some Extension I'm running under System 9, since others aren't finding the problem reproducible. Thanks for the input.
Post a reply