E-Maculation
https://emaculation.com/forum/

Hints please: Sheepshaver quits/freezes on launching Civ II
https://emaculation.com/forum/viewtopic.php?f=20&t=10560
Page 1 of 1

Author:  Alex [ Mon Mar 23, 2020 12:53 am ]
Post subject:  Hints please: Sheepshaver quits/freezes on launching Civ II

i installed Sheepshaver a month or so back to run some old games.

Sheepshaver v2.5, MacOS 9.04Z; MacOS X 10.13.6, iMac (27-inch, Late 2009), 16GB RAM.

Until today, everything worked okay - Sheepshaver would sometimes fail to start up for one reason or another, but a second attempt usually worked.

But starting from a few hours ago, trying to launch Civilization II (installed from a copy of the CD I bought many years ago) resulted in Sheepshaver either freezing or quitting.

I tried trashing various suspicious looking prefs files, but to no avail. In the end, I scrapped my Sheepshaver MacOS 9 boot disc image file, and set up a new boot disc, re-installing MacOS 9 from scratch. I then re-installed Civilization II from the installer.

But Civilization II still won't run - if I try to launch it, Sheepshaver once again either freezes or quits. This is quite strange, because Civilization II has run quite happily here on Sheepshaver up until a few hours ago. The only thing I can think of that's changed recently is that I installed the latest Adobe Flash update for MacOS X, but I can't see that that would have any effect on Sheepshaver.

I'd appreciate any troubleshooting hints anyone might have.

Author:  Ronald P. Regensburg [ Mon Mar 23, 2020 8:22 am ]
Post subject:  Re: Hints please: Sheepshaver quits/freezes on launching Civ

Did you delete the prefs and nvram files before setting up SheepShaver again? You can use the scripts that are included in the SheepShaver folder download.

Author:  Alex [ Mon Mar 23, 2020 4:52 pm ]
Post subject:  Re: Hints please: Sheepshaver quits/freezes on launching Civ

Thanks for the tip. No, I didn't try deleting the prefs or zapping NVAM.

Unfortunately, the SheepShaver scripts folder I have contains PowerPC applications, and my iMac is Intel so they don't run.

Am I right in thinking that the scripts in question delete the files:

~/.sheepshaver_nvram
~/.sheepshaver_prefs

- if so, I can delete those manually.

Thanks once more.

Author:  Ronald P. Regensburg [ Mon Mar 23, 2020 8:09 pm ]
Post subject:  Re: Hints please: Sheepshaver quits/freezes on launching Civ

I do not know how you got the older scripts. In the SheepShaver for Mac OS X (and OSX and macOS) download topic, you are informed that for a new SheepShaver 2.5 setup you should also download the SheepShaver folder. That folder contains the scripts for Intel 32 plus 64 bit.

But indeed, these scripts will delete the two files you mention.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/