Sheepshaver stopped opening on Windows

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
Yakkers
Space Cadet
Posts: 4
Joined: Thu Dec 25, 2014 2:40 am

Sheepshaver stopped opening on Windows

Post by Yakkers »

I've been using Sheepshaver for years, but the last time I tried to launch it nothing happens when I open the program. I get the usual 'The CD-ROM driver file "C:\WINDOWS\system32\drivers\cdenable.sys" is missing.' dialogue box which I've always gotten and just been able to click through, but after clicking okay nothing happens and Sheepshaver never starts. I didn't change anything at all, and I've tried taking my disk off and just booting via install disk but that doesn't seem to make a difference.

Is there anything here I can do to troubleshoot? I don't see a log file or anything, there are "stderr.txt" and "stdout.txt" but they're both empty. My best guess is that a Windows update borked something or something like that, but I would have no idea how to work it out. I'm using Windows 10 if that matters.
User avatar
ClockWise
Site Admin
Posts: 4032
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Re: Sheepshaver stopped opening on Windows

Post by ClockWise »

You sure it isn't just starting minimized? For some reason, it sometimes starts but is already minimized, with an icon down in the task bar. You don't see a window for even a moment in that case.

Meanwhile, on some versions of SheepShaver there aren't proper error messages when the path to the ROM is not correct. The emulator just fails to launch. Perhaps you can try reselecting the ROM file in the GUI.
Yakkers
Space Cadet
Posts: 4
Joined: Thu Dec 25, 2014 2:40 am

Re: Sheepshaver stopped opening on Windows

Post by Yakkers »

I made sure there wasn't a sheepshaver process running, so it's not just minimizing or anything. I tried reapplying the newworld86.rom just now and still no dice. Is there anything I could check to see if it's not accepting the rom for some reason?
User avatar
ClockWise
Site Admin
Posts: 4032
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Re: Sheepshaver stopped opening on Windows

Post by ClockWise »

Nothing really comes to mind.

I would just suggest deleting everything but the ROM and disk images you are using. Try downloading (the most recent version) and just setting it up from scratch. That should only take a couple minutes. If something is wrong in the prefs file that will take care of it.

Otherwise, you could try a different ROM image.
User avatar
Cat_7
Expert User
Posts: 5153
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Sheepshaver stopped opening on Windows

Post by Cat_7 »

Please copy the content of your sheepshaver_prefs file in your answer so we can see whether something looks out of order.

To get some info on what's happening you can try to start SheepShaver from the command line.
Open a cmd window, navigate to your SheepShaver folder and enter:
sheepshaver.exe

To upgrade to our latest build see here:
https://www.emaculation.com/doku.php/sheepshaver_setup

Best,
Cat_7
Yakkers
Space Cadet
Posts: 4
Joined: Thu Dec 25, 2014 2:40 am

Re: Sheepshaver stopped opening on Windows

Post by Yakkers »

I just dragged in my disks and newworld86.rom into a fresh download of the newest version and everything's golden now, I'm not sure why I didn't try that to begin with. I guess I hadn't really thought that Sheepshaver was still being updated and I also remembered it being a bit of a pain to set up, but with the disks already ready to go there's no actual setup involved.

Thanks for the help as always!
Post Reply