SheepShaver for Linux
Page 1 of 4

Author:  Cat_7 [ Fri Sep 03, 2010 11:16 am ]
Post subject:  SheepShaver for Linux

Thanks to our member vasi, some newer builds for Linux are available here:

Old first message in this thread:
A new SheepShaver build is available: http://www.open.ou.nl/hsp/downloads/She ... 7-2013.zip
It was built on Debian 7.1 64 bit with GCC 4.4, and has SDL support. Should work in windowed mode.
A build of SheepShaver for Linux is available that should support full-screen through SDL. It was built on Ubuntu 10.04/64 bit
Download here: http://www.open.ou.nl/hsp/downloads/She ... static.zip or
http://www.open.ou.nl/hsp/downloads/She ... tic.tar.gz
ADVISE: If you want to run full screen, the GUI doesn't allow you to set the refresh rate. Start with the "windowed" setting and set the refresh rate to e.g. 60, that setting will be preserved when you run full screen next time.

CAUTION: these builds are unstable when not in full-screen mode. You should use a Non-SDL build when running in a window. But then, those don't do full-screen.

The standard X-Window version that doesn't support full-screen is here:
http://www.open.ou.nl/hsp/downloads/She ... SDL.tar.gz

CentOS_x64 version without JIT, due to problems building the JIT version in 64 bit:
http://www.open.ou.nl/hsp/downloads/She ... no_Jit.zip

NOTE FOR OpenSuse USERS: OpenSuse uses AppArmor, which overrides the vmmap 0 setting. In order to run as a normal user, you have to disable AppArmor, or find a way to make a profile for SheepShaver that works. To try running without apparmor reboot and use the apparmor=0 parameter before you decide to turn it off with the system services yast tool.

The ubuntu network driver is here:
The OpenSuse network driver is here:
http://www.open.ou.nl/hsp/downloads/she ... o_SUSE.zip
The Debian network driver is here (Thanks to our forum member bmc5311 ). Build on 64bit Debian Squeeze kernel 2.6.32-5-amd64
http://www.open.ou.nl/hsp/downloads/she ... Debian.zip

Our SheepShaver for Linux instructions page is here (work in progress):


Author:  Cat_7 [ Fri Sep 03, 2010 1:49 pm ]
Post subject: 

But now for the 1 million dollar question: does it work?
(btw: I also did some work on the wiki)


Author:  ClockWise [ Fri Sep 03, 2010 2:09 pm ]
Post subject: 

It is working, but your build is crashing quite a lot. The older packages I used were stable, but I'm not getting that here. Crashes are very, very frequent.

Author:  ClockWise [ Fri Sep 03, 2010 2:12 pm ]
Post subject: 

For example, clicking the "Special" menu in my the mac os menu bar brings down the emulator every time.

Author:  Cat_7 [ Fri Sep 03, 2010 2:13 pm ]
Post subject: 

Perhaps you should leave the mouse along while Mac OS is starting. I believe that might be an SDL problem. I will try to build some version with the latest SDL later. The version I used now is the standard Ubuntu version.
I also have a version for X, but that doesn't do full-screen and starts at a preset low resolution like all old X versions do. But it is more stable.

Have you had any luck with the sheep_net driver? Can you get it installed following the wiki?


Author:  ClockWise [ Fri Sep 03, 2010 2:25 pm ]
Post subject: 

I get this message:

chown: changing ownership of `/dev/sheep_net': Operation not permitted

Author:  ClockWise [ Fri Sep 03, 2010 2:28 pm ]
Post subject: 

An update: Cat, your build is only crashy when I run in a window. In fullscreen mode it seems just fine!

Author:  Cat_7 [ Fri Sep 03, 2010 5:14 pm ]
Post subject: 

It should be "sudo chown username /dev/sheep_net"


Author:  ClockWise [ Sat Sep 04, 2010 4:25 am ]
Post subject: 


1. I have to enter "sudo sysctl -w vm.mmap_min_addr=0" upon every reboot of my system. This is the case with either build. Is there anything i can do to make this permanent?

2. On your new build, I don't get the "“Cannot map Low Memory Globals: Operation not permitted.” error message. it just fails to launch.

3. The full-screen mode is more stable than windowed, but the mouse is unresponsive enough to be almost un-useable. It is still smooth in the windowed mode.

Author:  Amade [ Sat Sep 04, 2010 10:15 am ]
Post subject: 

1. Edit your /etc/sysctl.conf file and add "vm.mmap_min_addr=0" inside

Author:  24bit [ Tue Sep 07, 2010 4:59 pm ]
Post subject:  Does nothing

Hello Cat7,
lots of thanks for your Linux version.
As for me, your release does just nothing on my Suse_Linux64 and EeeBuntu3.0 host systems.
Your old version works fine, but no fullscreen.
What a pity!

Author:  Cat_7 [ Tue Sep 07, 2010 5:07 pm ]
Post subject: 


Have you got the SDL libraries installed? The older versions don't use these, and (to me) it looks like the libraries were not statically linked even though I set that at compile-time.


Author:  24bit [ Tue Sep 07, 2010 11:27 pm ]
Post subject:  SDL 1.2

Hi Cat7,
libSDL-1.2 is installed. Is this the correct package?
The file is libSDL-1.2.so.0.11.2, at usr/lib64.

Author:  Cat_7 [ Wed Sep 08, 2010 6:38 am ]
Post subject: 

Yes, that should be OK.

I guess somehow the build process is a bit broken.


Author:  ClockWise [ Thu Sep 09, 2010 2:55 pm ]
Post subject: 

Cat_7... I'll replace the builds in the guide with links only to your builds. I think that with both of the builds you provide, and the tip to fix the refresh rate, the old 2006 packages are not necessary anymore.

Author:  ShavedSheeper [ Sat Oct 16, 2010 12:16 pm ]
Post subject:  Sheepshaver successfully running on Fedora 12 or Fedora 13?

Has anyone been able to run sheepshaver successfully under either of these Fedora Core versions?

I have tried all of the fixes suggested (changing sysctl.conf, etc) and it still gets the low memory error. I try to run Sheepshaver from the root-level command line and it also fails.


Author:  afrodeity [ Fri Nov 05, 2010 10:29 pm ]
Post subject: 

Good to see SheepShaver is alive on Linux. Still running the patched SheepShaver V2.3-Pre (Dec 15 2009) by Christian Bauer and Mar"c" Hellwig which seems a lot more stable on Ubuntu Maverick than Lucid. Fired it up tonight to open some old mac format data files and it works like a charm, but I'm sure it will probably crash if I try to run anything more than basic software like MS Word.

Just a question, is this new code, or is the 2006 code simply being repackaged?

Any changelogs or code available via Git?

Author:  Cat_7 [ Fri Nov 05, 2010 11:10 pm ]
Post subject: 


There is a cvs. You can view it through these links:

And a developer mailing list over here:
https://lists.sourceforge.net/lists/lis ... lisk-devel


Author:  ClockWise [ Mon Nov 15, 2010 2:55 pm ]
Post subject: 

I added a note about how to edit the sysctl.conf file that was sent in to me. Might make the guide easier to follow for new users.

Meanwhile, please let me know if there is any value to including a reference to the new linux package that was just posted to the forum.

Author:  maverickbna [ Sat Feb 26, 2011 5:44 am ]
Post subject: 

Is there any way you could compile this for CentOS 5.5 x86_64? Even a SRPM would be cool to have. I've had trouble in the past compiling SS on Linux.

Author:  Cat_7 [ Sat Feb 26, 2011 8:37 am ]
Post subject: 


Building for yet another specific Linux version is a bit troublesome for me, as I already run 5 different 32 linux flavours in VMWare on my Windows machine.

EDIT: a version for CentOS x64 without JIT functionality is available in the top posting.

There are packages for CentOS (also 64 bit) but from the older official source. Perhaps you can see if you can get by with one of them:


Author:  IPalindromeI [ Mon May 09, 2011 6:52 pm ]
Post subject: 

Here's a build from CVS, built on May 09, 2011. It is a 32-bit Debian package for Ubuntu and Debian. Sometimes I find the CVS builds break a lot, but I do know this build works, and surprisingly good!

http://ompldr.org/vOG1sdg/sheepshaver_2.3-3-cvs-20110905_i386.deb (please mirror this!)

Author:  notetabs [ Wed Nov 16, 2011 6:12 pm ]
Post subject:  Re: SheepShaver for Linux 03-09-2010 available

I'm using Lubuntu 11.10 x86_64

"SheepShaver_03_09_2010_SDL_static" doesn't launch when executed.

"SheepShaver_03-09_2010_NOSDL" does work.

The "vm.mmap_min_addr =" line is found in "/etc/sysctl.d/10-zeropage.conf".

Author:  luxor [ Sat Nov 19, 2011 4:45 am ]
Post subject:  Re: SheepShaver for Linux 03-09-2010 available

Hi! How do we run/install the "SheepShaver_03_09_2010_SDL_static" file? Its not a .deb or installer file.

Author:  ClockWise [ Sat Nov 19, 2011 5:03 am ]
Post subject:  Re: SheepShaver for Linux 03-09-2010 available

It is an executable, so it should just run.

If it doesn't run try the second one linked above:

http://www.open.ou.nl/hsp/downloads/She ... SDL.tar.gz

On my system (Ubuntu 10.10) the build you linked to doesn't launch (not sure why), but the above does.

Page 1 of 4 All times are UTC
Powered by phpBB® Forum Software © phpBB Group