Installation MacOS X Puma 10.1 no sound ?!

About PearPC, a PPC Mac emulator for Windows and Linux that can run MacOS X up to 10.4.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
Sebiohazard
Tinkerer
Posts: 57
Joined: Tue Aug 27, 2019 2:15 pm

Installation MacOS X Puma 10.1 no sound ?!

Post by Sebiohazard »

Good morning all !

I installed MacOS X Puma 10.1 with PearPC... the installation went well but I have no sound...

Image

Is this normal? Thanks best regards !
User avatar
adespoton
Forum All-Star
Posts: 3063
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by adespoton »

This is normal. If you want sound, you'll need to set up the Screamer build of QEMU, not PearPC. You should be able to use the drive image you set up in PearPC in QEMU.
Sebiohazard
Tinkerer
Posts: 57
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Sebiohazard »

OK thank you very much :cool:

QEMU is difficult to configure ? There is a tutorial ?
User avatar
Cat_7
Expert User
Posts: 4999
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Cat_7 »

guide here:
https://www.emaculation.com/doku.php/pp ... or-windows

If you download Qemu, make sure you download the build with experimental sound support.

Best,
Cat_7
Sebiohazard
Tinkerer
Posts: 57
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Sebiohazard »

Good evening !

I downloaded version 4.1 (06.09.2019) of QEMU unfortunately it does not work at home. In addition it misses the file qemu-img.exe in the archive ... I recovered it in the archive of the 3.1...

By contrast, version 3.1 (26.12.2018) works but after launching the emulator my hard drive is not recognized & I can not continue the installation...

Image

With PearPC my hard drive is recognized without problem why & how to proceed ?

Thanks best regards !
User avatar
Cat_7
Expert User
Posts: 4999
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Cat_7 »

Hi,

You have to use disk utility to partition and format the drive before it comes available to the installer.
Find that program in the menu.

Best,
Cat_7
Sebiohazard
Tinkerer
Posts: 57
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Sebiohazard »

Hello !

Thank you for your help I managed to initialize the HDD & start the installation of MacOS X ... I say start because I could not finish it... the installer told me that it remained more than 1h30 !!!

I do not understand the installation of MacOS X with PearPC took 14min...
Then I used a HDD with MacOS X installed with PearPC to launch it with QEMU but I had no sound...

I think QEMU is much less efficient than PearPC & still has a lot of bugs ?

Greetings !
User avatar
Cat_7
Expert User
Posts: 4999
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Cat_7 »

I think you will find Qemu has a lot less bugs compared to PearPC. It might be slower in some respects as it has no JIT compiler.
Also, PearPC has no sound support. To have some sound support in Qemu, you need to use one of our sound-enable builds. There is work being done on that front, but currently it is still deemed experimental.

https://surfdrive.surf.nl/files/index.p ... t/download
Please note you need to use all of that download, not just the qemu-system-ppc.exe
So download and place all files in a new folder. Also note that you cannot mix files from one download with the files from another download.

For optimal sound support, make sure you install the latest Quicktime and iTunes available for the OSX version you use.

Best,
Cat_7
User avatar
adespoton
Forum All-Star
Posts: 3063
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by adespoton »

It's also worth noting that if you want a performant OS to do things in, you should not use 10.1. It was the first "stable" version of OS X, but was by no means optimized. It was slow even on real hardware. 10.2 was the first one I could get real work done on; before that it was OS 9 as my day-to-day OS, and 10.1 for experimenting with the new technology. 10.3 was faster than 10.2, and 10.4 was, in most situations, faster than 10.3, but required more resources to accomplish this.

So if your goal is to run PPC OS X software, you should be installing OS X 10.4.5 or OS X 10.4.11. If you want sound, your only option is QEMU.

See https://docs.google.com/spreadsheets/d/ ... a2nWC9_t2w for the expanded list of what emulators support what OSes. If you're looking for computer equivalency, check out the second tab, which also highlights that if you want PMMU support, your only option is QEMU.

PearPC cheats a lot by offloading a bunch of functions to the host OS via the JIT emulator, and just not implementing a bunch of stuff (like the underlying hardware that the audio hardware and drivers use). This speeds it up for specific use cases, and causes it to totally fail at many edge cases. QEMU tries to accurately emulate all the original hardware, and in so doing, has to do a LOT more work, which causes some types of emulation (such as boot time initialization of all that emulated stuff) to be substantially slower. But there are very few things that will fail to work.

As Cat_7 has mentioned, floating point emulation is still slow, and a number of people (including me) have been poking at that over the last few years to figure out what's causing the slowdown, and whether it can be accelerated somehow. So far, there's been no quick wins, but there have been a number of incremental improvements over time. Likewise with audio, and also with video -- there's still no native hardware support, but the software rendering is now almost fully implemented, so most software will now run, even if it prefers a hardware GPU. PearPC just crashes when it encounters these unexpected conditions, although it gets there fast.

I hope this helps :)
Sebiohazard
Tinkerer
Posts: 57
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Sebiohazard »

@Cat_7 thanks for all the details !

@adespoton thank you for all these explanations ! Unfortunately I do not have other versions of MacOS X to try ... it's very difficult to find an ISO on the net ... would you have an address ?

I would like the sound to discover & play MacOS games is it possible to play ? Emulation will be too slow ?

Thanks best regards !
User avatar
24bit
Forum All-Star
Posts: 1404
Joined: Wed Nov 11, 2009 5:47 pm
Location: Germany

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by 24bit »

Macintoshgarden has a notable collection: https://macintoshgarden.org/apps/mac-osx-mac-os-10-ppc
For your Windows PC, .toast files may be renamed to .ISO. Same for .CDR mostly.
For .SIT files there is StuffitExpander for Windows - usually not recommended, but it should do for CD/DVD images.
DMG may be a problem, but luckily there are Windows tools to convert .DMG.
http://vu1tur.eu.org/tools/
Sebiohazard
Tinkerer
Posts: 57
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation MacOS X Puma 10.1 no sound ?!

Post by Sebiohazard »

Good evening everyone !

So I managed to install MacOS X with Qemu but I had a problem with my mouse that remained frozen at startup...

I solved the problem by modifying the qemu.bat file by replacing this parameter

Code: Select all

mac99,via=pmu
by this one

Code: Select all

mac99,via=cuda
I do not know if it's normal but it works ?!

Greetings !
Post Reply