Page 1 of 1

Mini vMac Raspberry Pi 4 - No Sound

Posted: Sun Nov 08, 2020 9:29 pm
by sam256
I’ve successfully compiled minivmac for a raspberry pi 4 using SDL1.2 using the following compile options:

Code: Select all

./setup_t -t larm -cpu arm -api sdl -m Plus -hres 512 -vres 384 -depth 0 -fullscreen 1 -magnify 1 -mf 2 -mem 4M -sound 1 -snd-api alsa >
Everything works except audio.

Sound works fine otherwise on the Pi, including in Basilisk II compiled with SDL1.2. I'm using an onboard sound card with amp, which is set as the default device (hw:0,0)--onboard sound and hdmi sound are both disabled at boot. And again, it all works fine with other apps.

I looked in the source code and it appears Mini vMac will get the Alsa device from an AUDIODEV environmental variable. (It does not accept the -alsadev command line parameter when compiled for SDL.). I've tried setting that to hw:0,0 explicitly, but that doesn't change anything.

I've also tried compiling with ddsp as the -snd-api option; no luck.

(BTW, I've tried compiling for SDL2. It gives me weird redraw issues..and doesn't solve the audio issue).

Any ideas? Much appreciated.

Re: Mini vMac Raspberry Pi 4 - No Sound

Posted: Fri Nov 20, 2020 11:55 am
by sam256
This looks like it may be related to the soundcard "hat" I'm using on my raspberry which uses the snd_rpi_hifiberry_amp driver enabled by "dtoverlay=hifiberry-amp" in my /boot/config.txt

I got minivmac to work in SDL mode by going in to the source code (OSGLUSDL.c) and manually doubling the frequency to 44510 (ln 2354 of OSGLUSDL.c).

I've emailed the minivmac maintainer to see if he has any better ideas, but for now this has gotten sound working for me.