Login  •  Register


The time is now: Mon Dec 10, 2018 11:52 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 6 posts ]
Print view Previous topic  |  Next topic
Author Message
 Post subject: Running Arkanoid
PostPosted: Sat Sep 01, 2018 5:33 am 
Offline
Space Cadet

Joined: Sat Sep 01, 2018 5:05 am
Posts: 3
Hi,

my main goal is to run the original black and white Arkanoid (my adult daughter would like relive her childhood).

So I'm open to other approaches that what I've attempted here.

Ok, so to my problems:

I'm running on MacOs 10.13.6 High Sierra with Mini vMac version minivmac-3.5.8-mc68.

The first problem is that vMac does not find the ROM image if I place it in the same folder as 'Mini vMac.app' file. If I place the ROM image into 'Mini vMac.app/Contents/MacOS/' next to the actual executable 'minivmac' and then double click that executable then the vMac start fine and finds the ROM image. But will still not find the ROM image if I start it from the .app icon. Minor inconvenience but would be nice if it worked as intended.


Next I drag the System 6.0.8 icon on to the emulator window and the Mac boots nicely, so no problem there.

I then drag the file 'Arkanoid_1_00.dsk' in to the emulator and it asks me if I want initialise the disk or eject it. I always eject it.

Image

I then drag the file 'Arkanoid_1_10.dsk' in to the emulator and the disk mounts and I can start Arkanoid by double clicking at its icon. But Arkanoid gives error message about not being able to allocate alternate sound and screen buffers and suggest that I should use System 6.0.2 or later or boot from the Arkanoid 1.10 disk.

Image

I've tried that but of course that fails cause there is no system on that disk.

I go the .dsk images from here:

https://www.macintoshrepository.org/6122-arkanoid

and I've not been able to find an other source.

At this point I'm stuck and help would be appreciated.


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Running Arkanoid
PostPosted: Sat Sep 01, 2018 8:24 am 
Offline
Forum All-Star

Joined: Wed Nov 11, 2009 5:47 pm
Posts: 1160
Location: Germany
Same error here with MiniVMac (Mac+), System 6.08 on a Sierra host.

The game runs with MinVMac (Mac II) though, looks like SheepShaver does work too but Basilisk II may be the way to go.

Image

There are a few files hosted here since 2009, no Idea whether MacRepo already ripped them off.
http://macintoshgarden.org/games/arkanoid


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Running Arkanoid
PostPosted: Mon Sep 03, 2018 5:50 pm 
Offline
Space Cadet

Joined: Sat Sep 01, 2018 5:05 am
Posts: 3
Thanks for the tip, got it working now!

For the posterity this is my setup:

Image

I got my files from here:


Mac II emulator:

https://www.gryphel.com/c/minivmac/dnld_mii.html


Mac II ROM image:

https://github.com/nyteshade/mini-vmac- ... /MacII.ROM


The System Startup disk:

https://www.gryphel.com/c/minivmac/dnld_mii.html
- note that MacOs Arhieve Utility fails to open the file, use Unarchaiver


Arkanoid:

https://www.macintoshrepository.org/6122-arkanoid
- it is the 3+ MB zip file
- specically from this link https://www.macintoshrepository.org/dow ... hp?id=9182



To start do as follows:

1) Drag 'System Startup-1' to the 'Mini vMac 26'
(starting by double clicking the Mini vMac icon does not work)
2) Drag 'Arkanoid_1_110.dsk' to the desktop of the emulated Mac
3) Start Arkanoid by double clicking the Arkanoid app icon


Above has been tested on MacOs High Sierra with files I downloaded at this point in time.


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Running Arkanoid
PostPosted: Wed Sep 05, 2018 12:52 pm 
Offline
Nice Guy
User avatar

Joined: Sat Nov 17, 2007 6:46 pm
Posts: 105
nyholku wrote:
I'm running on MacOs 10.13.6 High Sierra with Mini vMac version minivmac-3.5.8-mc68.

The first problem is that vMac does not find the ROM image if I place it in the same folder as 'Mini vMac.app' file.


This is due to the Path Randomization misfeature added in macOS Sierra (10.12). There are some work arounds, as described in my OS X notes page, which is linked to from the downloads page and the getting started page. I'm not sure how to make this harder to miss.

For the next version of Mini vMac, I found a way to find the original application folder even with Path Randomization. But it uses an undocumented function of OS X, so using it would likely just cause more problems in the future. Instead the next version, hopefully in beta soon, will allow dragging and drop the ROM image onto the Mini vMac window, if the ROM image isn't found in any of the locations in looks for it.

nyholku wrote:
I then drag the file 'Arkanoid_1_00.dsk' in to the emulator and it asks me if I want initialise the disk or eject it. I always eject it.


It looks like this image is intended to be in Disk Copy 4.2 format, but the header is incorrect. So Mini vMac just treats it like a regular image, which doesn't work either. Stripping off the first 84 bytes of the image would allow it to work well enough.

nyholku wrote:
I then drag the file 'Arkanoid_1_10.dsk' in to the emulator and the disk mounts and I can start Arkanoid by double clicking at its icon. But Arkanoid gives error message about not being able to allocate alternate sound and screen buffers and suggest that I should use System 6.0.2 or later or boot from the Arkanoid 1.10 disk.


I think this is because of something odd about the System 6 installer disk that you have booted from. If you used the installer disk to create a normal System 6 disk (such as described in the System 6 utility disk Recipe for Mini vMac), Arkanoid would work fine from the new boot disk.


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Running Arkanoid
PostPosted: Thu Sep 06, 2018 2:34 pm 
Offline
Space Cadet

Joined: Sat Sep 01, 2018 5:05 am
Posts: 3
Quote:
I'm not sure how to make this harder to miss.


Touche! :oops: Well my only defence is that I'm a Mac user :wink: :smile:

Incidentally I tried the the xattr trick and seem it does not work in High Sierra anymore :sad:

BTW Thank you for all the work done on the emulator, my adult daughter just love playing her childhood favourite game!


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Running Arkanoid
PostPosted: Fri Sep 07, 2018 11:17 am 
Offline
Nice Guy
User avatar

Joined: Sat Nov 17, 2007 6:46 pm
Posts: 105
nyholku wrote:
Touche!


Sorry, that should be read as a question of how to improve the documentation. Of course, the best way to improve the documentation is to make it unnecessary.

nyholku wrote:
Incidentally I tried the the xattr trick and seem it does not work in High Sierra anymore


Thanks for the report. That wouldn't surprise me at all. Unfortunately, I have not been able to reproduce this, in 10.13.6. Something may be different in my set up.

Anyway, it would be better to make xattr unnecessary, and not to try to work around Apple's intentions. Hence, code signing for the next version, and support for dragging and dropping the ROM image.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 6 posts ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group