Qemu-system-m68k for macOS to run MacOS 7.1-8.1

About Qemu-system-m68k, a m68k Mac emulator for Windows, macOS and Linux that can run MacOS 7.1 to 8.1, AUX 3.x and NetBSD

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

Qemu can now also run MacOS 7.1 to 8.1!

Download the alpha build for macOS here: https://surfdrive.surf.nl/files/index.p ... Z/download
Guide: https://www.emaculation.com/doku.php/m68k-qemu-on-osx

Best,
Cat_7
emendelson
Forum All-Star
Posts: 1438
Joined: Tue Oct 14, 2008 12:12 am

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by emendelson »

Looks fascinating! But the guide includes an incomplete link that says "Go to xxxxxxxx." Thank you!
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

Ha, fixed. But you did find the place to download ;-)
emendelson
Forum All-Star
Posts: 1438
Joined: Tue Oct 14, 2008 12:12 am

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by emendelson »

Cat_7 wrote: Sat Aug 28, 2021 1:33 pm But you did find the place to download ;-)
It wasn't too hard to find....!
dotbk
Space Cadet
Posts: 2
Joined: Fri Sep 03, 2021 3:29 am

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by dotbk »

both macOS versions seem to be for AUX
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

How so?
Can you not boot Mac OS 7 or 8?

Best,
Cat_7
dotbk
Space Cadet
Posts: 2
Joined: Fri Sep 03, 2021 3:29 am

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by dotbk »

Get a sad Mac 0000000F when the CDROM is in the config. I've tried using the MATSHITA/CD-ROM CR-8005/1.0k in the guide and the stock SONY/CD-ROM CDU-8003A/1.8f. I'm using a Quad610.ROM from a working Q800. Originally thought it was my ISOs, with them locked and unlocked. But I tried a few known bootable ISOs that do boot when burned to CD.
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

Yes, I've seen that too sometimes.
You could check the cd images with:
dd if=yourimage.img bs=512 count=16 | hexdump -C

If the first 2 bytes are not ER, the image is not a complete disk image.

You might also create a new pram file, or try to run without pram file, or try to change the scsi id's of the drives.

Best,
Cat_7
jonirob
Tinkerer
Posts: 51
Joined: Tue Jan 29, 2019 6:03 pm

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by jonirob »

I've had no problems installing Mac OS 8.0 and 7.5.3 on Windows 10, though in both instances double click does not work.
peanutbutter71
Space Cadet
Posts: 4
Joined: Sun Sep 05, 2021 3:44 am

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by peanutbutter71 »

dotbk wrote: Fri Sep 03, 2021 4:25 am Get a sad Mac 0000000F when the CDROM is in the config. I've tried using the MATSHITA/CD-ROM CR-8005/1.0k in the guide and the stock SONY/CD-ROM CDU-8003A/1.8f. I'm using a Quad610.ROM from a working Q800. Originally thought it was my ISOs, with them locked and unlocked. But I tried a few known bootable ISOs that do boot when burned to CD.
I get the same thing. I compiled it on Linux though. I tried multiple ISOs and also checked that they start with ER. It starts up, I hear the chime, and then get the sad mac.
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

I've had no problems installing Mac OS 8.0 and 7.5.3 on Windows 10, though in both instances double click does not work.
The default gtk interface has issues with double-click speed in Windows.
You can try to add "-sdl" to the command line.

Best,
Cat_7
jonirob
Tinkerer
Posts: 51
Joined: Tue Jan 29, 2019 6:03 pm

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by jonirob »

Thanks Cat_7, that worked.
LightBulbFun
Tinkerer
Posts: 50
Joined: Mon Jul 13, 2015 11:32 am

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by LightBulbFun »

Oh wow! awesome to see QEMU can now Boot the Toolbox ROM and boot Mac OS and AU/X, im going to have lots of fun playing with this :)

for what its worth I ran into the sad mac issues also, but compiling from the source code solved that issue for me

I noticed even in the OS X precompiled download the executable binary still has AU/X in its file name so I wonder if something got mixed up?
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

I noticed even in the OS X precompiled download the executable binary still has AU/X in its file name so I wonder if something got mixed up?
I see, indeed some mix-up ;-)
Luckily I still had the correct build so I uploaded it. First post is updated with the correct link.

If you compile your own from https://gitlab.com/mcayland/qemu/-/tree/q800.upstream that build will be for running MacOS, if you revert the last commit to the branch you can run AUX.

Best,
Cat_7
erichelgeson
Space Cadet
Posts: 1
Joined: Thu Oct 28, 2021 6:10 pm

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by erichelgeson »

Tested this out, works great! Do you have any tips on getting NetBSD 9.2 X11 to start correctly?
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

Hi,

Unfortunately I can´t help you there.

Best,
Cat_7
mcayland
Granny Smith
Posts: 131
Joined: Sun Nov 01, 2015 10:33 pm

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by mcayland »

erichelgeson wrote: Thu Oct 28, 2021 6:12 pm Tested this out, works great! Do you have any tips on getting NetBSD 9.2 X11 to start correctly?
The patches were tested against NetBSD 9.2 which exposed a couple of bugs in the latest release. With a vanilla 9.2 install you can launch X if you use a WSFB kernel instead of a GENERIC kernel and the following xorg.conf:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "Protocol" "wskbd"
EndSection
Hopefully the developers will be able to fix these issues soon in time for the next NetBSD release.
User avatar
Nowhere Man
Student Driver
Posts: 14
Joined: Sun Sep 30, 2018 4:38 am

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Nowhere Man »

All I'm getting from trying this is errors. I tried the allow script and got:

Qemu-system-m68k-alpha % /Users/.../Desktop/Qemu-system-m68k-alpha/allow_qemu_to_run-m68k.command
xattr: ./qemu-system-m68k-MacOS-alpha: No such xattr: com.apple.quarantine
xattr: ./qemu-img: No such xattr: com.apple.quarantine
xattr: No such file: ./pram-aux.img
xattr: ./Libs: No such xattr: com.apple.quarantine
xattr: ./Libs/libffi.7.dylib: No such xattr: com.apple.quarantine
xattr: ./Libs/libgmodule-2.0.0.dylib: No such xattr: com.apple.quarantine
xattr: ./Libs/libgio-2.0.0.dylib: No such xattr: com.apple.quarantine
xattr: ./Libs/libgobject-2.0.0.dylib: No such xattr: com.apple.quarantine
xattr: ./Libs/libglib-2.0.0.dylib: No such xattr: com.apple.quarantine
xattr: ./Libs/libintl.8.dylib: No such xattr: com.apple.quarantine
xattr: ./Libs/libpcre.1.dylib: No such xattr: com.apple.quarantine
xattr: ./Libs/libpixman-1.0.40.0.dylib: No such xattr: com.apple.quarantine


I've done the chmod +x to the script to run the alpha QEMU build, but only get a File Vault error telling me:

“qemu-macos.command” is damaged and can’t be opened. You should move it to the Trash.
User avatar
Cat_7
Expert User
Posts: 5640
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Cat_7 »

These messages are normal after you ran the allow_qemu_to_run script once before (the attributes would have been removed already).

But I see one small issue in the script: it should read
xattr -d com.apple.quarantine ./pram-macos.img
instead of
xattr -d com.apple.quarantine ./pram-aux.img

You can fix that before running the script. It should, however, not impede running Qemu.

As to why the qemu-macos.command is damaged, I have no idea.
But you can create your own command file with the content of the original file and make it executable.

Content was:

#!/bin/bash
cd "$(dirname "$0")"

./qemu-system-m68k-MacOS-alpha \
-L pc-bios \
-M q800 \
-bios Quadra800.rom \
-drive file=pram-macos.img,format=raw,if=mtd \
-device scsi-hd,scsi-id=0,drive=hd0,vendor="SEAGATE",product="ST225N",ver="1.0" \
-drive file=MacOS8.0.img,media=disk,format=raw,if=none,id=hd0 \
-device scsi-cd,scsi-id=3,drive=cd0,vendor="MATSHITA",product="CD-ROM CR-8005",ver="1.0k" \
-drive file=MacOS8.0.iso,media=cdrom,if=none,id=cd0

Best,
Cat_7
Splot
Space Cadet
Posts: 2
Joined: Sun Jan 16, 2022 9:18 pm

Re: Qemu-system-m68k for macOS to run MacOS 7.1-8.1

Post by Splot »

Some notes that may be of use to others...

Mac OS 8.0:

This installed like a dream - pretty much follow the guide and then click through the installer. Networking was functional out of the box.

System 7.5.3:

None of the disk images I tried to use were able to perform the initial disk initialisation. However I was able to initialise a disk with the install medium I used for Mac OS 8.0 and, after that, the 7.5.3 install image I tried worked perfectly. I have yet to try the network with this VM.
Post Reply