Sheepshaver won't open on M1 Pro Mac (version 12.0)

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
Clovett996
Student Driver
Posts: 10
Joined: Sat Oct 30, 2021 2:18 pm

Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Clovett996 »

Just tried to download and run Sheepshaver on a new M1 Pro MBP with macOS Monterey (12.0). Here is a pic of my Sheepshaver folder, I followed the setup guide in the wiki.

Image
User avatar
Ronald P. Regensburg
Expert User
Posts: 7255
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Ronald P. Regensburg »

(If you want to show an image here, you need to link to the location of the image itself, not to the web page on which it appears. I corrected the link for you.)

I cannot see in the screenshot if the ROM file possibly has a (hidden) file name extension. Did you check that in Finder Info for the file?

BTW: Make sure you update to Monterey 12.0.1 !
Clovett996
Student Driver
Posts: 10
Joined: Sat Oct 30, 2021 2:18 pm

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Clovett996 »

Thanks, I appreciate it. Will update my OS.

I don't think there is an extension. Here's a screenshot
Image.
Last edited by Clovett996 on Sat Oct 30, 2021 4:47 pm, edited 2 times in total.
User avatar
Ronald P. Regensburg
Expert User
Posts: 7255
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Ronald P. Regensburg »

So the name of the rom file is not an issue.

The latest SheepShaver build runs fine in macOS 11.6.1 on M1, I see no reason why it would not run in 12.0.1 on M1 Pro.

Did you migrate stuff, specifically the user, from an older Mac that did have a previous SheepShaver setup? If so, you will have migrated the hidden ~/.sheepshaver_prefs file that may now interfere with creating a new setup. Use the scripts in the SheepShaver Scripts folder to delete the old files. The scripts are not yet Apple Silicon native, so you will need to install Rosetta to run them.

Alternatively you can trash the files manually:
- Open your Home folder
- Hit command-shift-. (command-shift-dot)
- Look for these now visible files and trash them: .sheepshaver_prefs and .sheepshaver_nvram
- Again hitting command-shift-. will again hide the normally hidden files

If migrating old SheepShaver files is not the issue or if removing the files does not solve the problem, you can try this:

- Copy SheepShaver (only the app itself) to a different location (like your desktop)
- Delete the original app
- Move the copy back into the SheepShaver folder
Clovett996
Student Driver
Posts: 10
Joined: Sat Oct 30, 2021 2:18 pm

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Clovett996 »

Hi, nothing has been migrated and it still would not open when I tried copying and replacing Sheepshaver.

However, I downloaded E. Mendelson's build from columbia.edu (http://www.columbia.edu/~em36/macos9osx.html) and it has opened Mac OS 9 on my M1 Pro MBP running macOS Monterey (v12.0.1). Will try downloading apps next. Thanks for your help.
User avatar
flaurens
Space Cadet
Posts: 6
Joined: Fri Jan 21, 2022 10:10 pm
Location: France

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by flaurens »

Hello,
I have a similar problem:
My SheepShaver (2.5) setup, which worked perfectly on an old (2010) Intel MacBook Pro (running High Sierra), doesn't seem to work on my M1 MacBook Pro (running Monterey 12.1):
the application doesn't start (quits immediately) when I try to open my Mac OS 9 VM, unless I set the SheepShaver application to open with Rosetta.
With Rosetta, it does run correctly.

Is there something to tweak in the SheepShaver preferences / Virtual Machine settings to get it to work without Rosetta?

Regards,
Last edited by flaurens on Fri Jan 21, 2022 10:36 pm, edited 2 times in total.
--FL
User avatar
Ronald P. Regensburg
Expert User
Posts: 7255
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Ronald P. Regensburg »

That is strange. SheepShaver runs fine here (and for many other users) natively in Monterey on M1. The discussion in this thread with "Clovett996" stopped before we could find the cause.

Which SheepShaver build (date!) do you use?

Did you migrate from your previous (Intel) Mac or is this a new installation and setup?

Where is SheepShaver installed?

Please post here the contents of your prefs file:
- Open your Home folder
- Press Command-Shift-dot (hidden files will become visible)
- Find the file .sheepshaver_prefs and open it in TextEdit
- Select all, copy, and paste in your reply
(Again pressing Command-Shift-dot will again hide the hidden files.)
User avatar
flaurens
Space Cadet
Posts: 6
Joined: Fri Jan 21, 2022 10:10 pm
Location: France

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by flaurens »

Hello,

- This is SheepShaver 2.5 (1 August 2021), which I was already using on my Intel MBP.

- This is a migration from the Intel MBP to the M1 MBP.

- SheepShaver is installed in my home (~/Applications) Applications folder.

- I do not have a ~/.sheepshaver_prefs file, since I use a self-contained SheepVM.
Here is the contents of the VM's embedded prefs file:

Code: Select all

disk Mac OS 9.sheepdsk
cdrom /dev/poll/cdrom
extfs /Users/fl/Documents/Comptes
screen win/1024/768
windowmodes 0
screenmodes 0
seriala
serialb /dev/null
rom Mac OS ROM 1.6
bootdrive 0
bootdriver 0
ramsize 1073741824
frameskip 0
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
ignoreillegal false
jit false
jit68k false
keyboardtype 5
hardcursor false
hotkey 0
scale_nearest false
scale_integer false
cpuclock 0
yearofs 0
dayofs 0
mag_rate 0
swap_opt_cmd false
sound_buffer 0
name_encoding 0
ether
keycodes true
keycodefile keycodes
mousewheelmode 0
mousewheellines 1
dsp /dev/dsp
mixer /dev/mixer
idlewait true
--FL
User avatar
Ronald P. Regensburg
Expert User
Posts: 7255
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Ronald P. Regensburg »

Apparently an issue with RAM settings that was not identified earlier. I can confirm it here on my machine.

With RAM size set to 1024 MB SheepShaver will crash on launch when run natively on M1. It wil run, though, if set (in Finder Info) to run with Rosetta.

With RAM size set to 512 MB SheepShaver will run fine natively on M1.

Try editing the prefs file and replace

Code: Select all

ramsize 1073741824
by

Code: Select all

ramsize 536870912
User avatar
flaurens
Space Cadet
Posts: 6
Joined: Fri Jan 21, 2022 10:10 pm
Location: France

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by flaurens »

Ronald P. Regensburg wrote: Sun Jan 23, 2022 11:58 am With RAM size set to 1024 MB SheepShaver will crash on launch when run natively on M1. It wil run, though, if set (in Finder Info) to run with Rosetta.
With RAM size set to 512 MB SheepShaver will run fine natively on M1.
Indeed. Thanks for the tip.

I also tried 768MB, it works fine in M1 native mode.
I also tried (for the sake of it) 1023MB: works fine with Rosetta, but crashes in M1 native mode.

By the way, it seems that it is impossible to set RAM size to a value > 1024MB (never noticed that before...).
--FL
User avatar
adespoton
Forum All-Star
Posts: 3694
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by adespoton »

flaurens wrote: Sun Jan 23, 2022 1:34 pm
Ronald P. Regensburg wrote: Sun Jan 23, 2022 11:58 am With RAM size set to 1024 MB SheepShaver will crash on launch when run natively on M1. It wil run, though, if set (in Finder Info) to run with Rosetta.
With RAM size set to 512 MB SheepShaver will run fine natively on M1.
Indeed. Thanks for the tip.

I also tried 768MB, it works fine in M1 native mode.
I also tried (for the sake of it) 1023MB: works fine with Rosetta, but crashes in M1 native mode.

By the way, it seems that it is impossible to set RAM size to a value > 1024MB (never noticed that before...).
SheepShaver doesn't run an OS that can handle > 1024MB RAM, so this generally isn't an issue. Even Mac OS 9.2.2 can only handle 1024 MB on real hardware. There's been a good analysis of that over on 68kmla; they discovered that there's other instructions located in the memory address above that. Some people have hacked the ROM image to shuffle things around to remove this problem, and were able to get 2048MB showng reported... however, only 1024 of it was usable, with the other 1024 sitting usable in the System memory stack.
User avatar
flaurens
Space Cadet
Posts: 6
Joined: Fri Jan 21, 2022 10:10 pm
Location: France

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by flaurens »

adespoton wrote: Mon Jan 24, 2022 5:55 am SheepShaver doesn't run an OS that can handle > 1024MB RAM, so this generally isn't an issue.
Indeed.
A slight improvement to SheepShaver preferences dialog would be to gracefully prevent user from attempting to set RAM size to a value > 1024MB.
--FL
User avatar
Ronald P. Regensburg
Expert User
Posts: 7255
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Ronald P. Regensburg »

The developer kanjitalk755 fixed the crash with 1024MB RAM. I will post a new build shortly.

A slight improvement to SheepShaver preferences dialog would be to gracefully prevent user from attempting to set RAM size to a value > 1024MB.
kanjitalk755 is not interested in working on the prefs editor, so others would need to offer pull requests for changes in the prefs editor and its GUI.

(This is also the reason why none of the new 'advanced' features can be set in the prefs editor GUI. They need to be set by editing the prefs file in a text editor as described in the setup manual.)
User avatar
flaurens
Space Cadet
Posts: 6
Joined: Fri Jan 21, 2022 10:10 pm
Location: France

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by flaurens »

Ronald P. Regensburg wrote: Mon Jan 24, 2022 11:43 am The developer kanjitalk755 fixed the crash with 1024MB RAM. I will post a new build shortly.
Thanks a lot!
Ronald P. Regensburg wrote: Mon Jan 24, 2022 11:43 am (This is also the reason why none of the new 'advanced' features can be set in the prefs editor GUI. They need to be set by editing the prefs file in a text editor as described in the setup manual.)
Thanks for the info. I was not aware of this (since before my Intel>M1 switch I had basically not changed my prefs in years ;-)).
I'll have a look at the revised setup manual.
--FL
User avatar
Ronald P. Regensburg
Expert User
Posts: 7255
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Ronald P. Regensburg »

Posted the the new build with fix for the crash with RAM set to 1024MB.
User avatar
flaurens
Space Cadet
Posts: 6
Joined: Fri Jan 21, 2022 10:10 pm
Location: France

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by flaurens »

Ronald P. Regensburg wrote: Mon Jan 24, 2022 7:38 pm Posted the the new build with fix for the crash with RAM set to 1024MB.
It works nicely. Thanks a lot!
--FL
Just_Phill
Space Cadet
Posts: 1
Joined: Tue Feb 01, 2022 12:59 pm

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Just_Phill »

Hi,

I can't get this to load on a M1 MacBook Pro using 12.1.

I've downloaded the 24/01/22 version and changed the RAM settings as mentioned in a previous post but still no joy.

I have copied the text file below and any help would be appreciated.

Many Thanks

Just_Phill

extfs /
windowmodes 0
screenmodes 0
seriala /dev/cu.Bluetooth-Incoming-Port
serialb /dev/null
bootdrive 0
bootdriver 0
ramsize 536870912
frameskip 8
gfxaccel true
nocdrom false
nonet false
nosound false
nogui false
noclipconversion false
ignoresegv true
ignoreillegal false
jit false
jit68k false
keyboardtype 5
hardcursor false
hotkey 0
scale_nearest false
scale_integer false
cpuclock 0
yearofs 0
dayofs 0
mag_rate 0
swap_opt_cmd false
sound_buffer 0
name_encoding 0
keycodes false
mousewheelmode 1
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
idlewait true
User avatar
Ronald P. Regensburg
Expert User
Posts: 7255
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Ronald P. Regensburg »

As far as I can see, you did not set up SheepShaver. No way SheepShaver can run like this.

Read and follow all steps in our setup guide: https://www.emaculation.com/doku.php/sh ... os_x_setup
Clovett996
Student Driver
Posts: 10
Joined: Sat Oct 30, 2021 2:18 pm

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Clovett996 »

Hello again, I've tried the Jan 2022 build but now when I try to run Sheepshaver with the Mac OS 9.0.4 universal ISO, I get the error "'The system software on the startup disk only functions on the original media , not if copied to another driver''.

EDIT: .img file is locked in read-only mode, so that is not the problem.
User avatar
adespoton
Forum All-Star
Posts: 3694
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by adespoton »

Clovett996 wrote: Fri Feb 25, 2022 12:26 am Hello again, I've tried the Jan 2022 build but now when I try to run Sheepshaver with the Mac OS 9.0.4 universal ISO, I get the error "'The system software on the startup disk only functions on the original media , not if copied to another driver''.

EDIT: .img file is locked in read-only mode, so that is not the problem.
In SheepShaver builds from the last few years, you need to check the "CD" checkbox in the prefs instead of the old "lock the file" hack.
Clovett996
Student Driver
Posts: 10
Joined: Sat Oct 30, 2021 2:18 pm

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by Clovett996 »

adespoton wrote: Fri Feb 25, 2022 1:22 am
Clovett996 wrote: Fri Feb 25, 2022 12:26 am Hello again, I've tried the Jan 2022 build but now when I try to run Sheepshaver with the Mac OS 9.0.4 universal ISO, I get the error "'The system software on the startup disk only functions on the original media , not if copied to another driver''.

EDIT: .img file is locked in read-only mode, so that is not the problem.
In SheepShaver builds from the last few years, you need to check the "CD" checkbox in the prefs instead of the old "lock the file" hack.
Thanks, I thought I had the CD box checked but when I looked again I noticed I had "Mac OS 9" checked instead of "Mac OS 9.toast". It seems to be working now! :cool:
caity2k
Space Cadet
Posts: 1
Joined: Sat Mar 12, 2022 10:21 pm

Re: Sheepshaver won't open on M1 Pro Mac (version 12.0)

Post by caity2k »

Ronald P. Regensburg wrote: Sat Oct 30, 2021 9:15 pm So the name of the rom file is not an issue.

The latest SheepShaver build runs fine in macOS 11.6.1 on M1, I see no reason why it would not run in 12.0.1 on M1 Pro.

Did you migrate stuff, specifically the user, from an older Mac that did have a previous SheepShaver setup? If so, you will have migrated the hidden ~/.sheepshaver_prefs file that may now interfere with creating a new setup. Use the scripts in the SheepShaver Scripts folder to delete the old files. The scripts are not yet Apple Silicon native, so you will need to install Rosetta to run them.

Alternatively you can trash the files manually:
- Open your Home folder
- Hit command-shift-. (command-shift-dot)
- Look for these now visible files and trash them: .sheepshaver_prefs and .sheepshaver_nvram
- Again hitting command-shift-. will again hide the normally hidden files

If migrating old SheepShaver files is not the issue or if removing the files does not solve the problem, you can try this:

- Copy SheepShaver (only the app itself) to a different location (like your desktop)
- Delete the original app
- Move the copy back into the SheepShaver folder

Thank you so much for these particular instructions. They helped me with my issue. I couldn't open SheepShaver on Mac OS Monterey 12.2.1. I tried deleting the app and reinstalling it again, rebooting my computer, creating an entirely new SheepShaver setup, and nothing worked until I found these instructions. I'm new to virtualization and troubleshooting this kind of stuff can sometimes be really challenging. Thanks again!
Post Reply